Batch upload error: Archive does not exist

  • Hi,

    I have a zipfile with the jpg files, but when I try the batch upload I got error like this:

    Archive does not exist at /web/htdocs/www.rivaronesi.it/home/administrator/components/com_joomgallery/temp/WhatsApp Zip 2019-09-15 at 22.11.26-52516/WhatsApp Zip 2019-09-15 at 22.11.26.zipBest,

    M

    PS.: When I look for joomgallery google redirect me to the old site/forum and in the old forum I do not see a clear message to use this new one. I would suggest to make this more clear.

  • Hi,


    this is an old problem that is caused with an update of joomla in 2015:

    The Joomla security checks were increased. Due to these tightened security checks, many Zip files are considered "insecure" and the upload is failed.


    If it absolutely has to be the Zip upload (although the Drag'n'Drop upload is much better in my opinion) there are two possible solutions:


    1st possibility: to pack the files with another Zip program. This may work - but does not have to.


    2nd possibility: To "disable" the security checks of Joomla for the upload. Many other Joomla extensions have done this. Of course you should think twice about this step and be sure to upload only safe Zip files.

    This possibility has already been discussed on Github.

    I think it is possible to creating an option in the Configuraton Manager so that the admin has the ability to disable the security checks for the backend?

    So far that has not been implemented. Maybe we have to discuss it again?


    Regards

    MrMusic

  • I do not know, I thought that this was due to the unzip procedure since is quite wired having the directory with the same name of the zip file (It seems to me that you do not just use the "unzip command", but you first create a directory, right?).


    Another question, related to my PS in the previous post: I do not find the option to receive an email when someone reply to my post. Where is it? Thanks!

  • This option can be found in the user account settings.
    Go to "User Account - Settings - Notifications".
    There the second setting is what you are looking for. Default is without email notification. But you can change that as you wish...

    I hope, I could help

    Thanks!